к алгоритмизации   алгоритмы, струкутуры данных и программирование   СУБД   ЯиМП   3GL   4GL   5GL   технологии прогр.

Вложенные циклы и их особенности

Возможны случаи, когда внутри тела цикла необходимо повторять некоторую последовательность операторов, т. е. организовать внутренний цикл. Такая структура получила название цикла в цикле или вложенных циклов. Глубина вложения циклов (то есть количество вложенных друг в друга циклов) может быть различной.

При использовании такой структуры для экономии машинного времени необходимо выносить из внутреннего цикла во внешний все операторы, которые не зависят от параметра внутреннего цикла.

Пример вложенных циклов   для  

Вычислить сумму элементов заданной матрицы А(5,3).
 
            Матрица А            
 
 S := 0;
 нц для i от 1 до 5
   нц для j от 1 до 3
     S:=S+A[i,j]
   кц
 кц

Пример вложенных циклов   пока  

Вычислить произведение тех элементов заданной матрицы A(10,10), которые расположены на пересечении четных строк и четных столбцов.
 
 i:=2; P:=1
 нц пока i <= 10
   j:=2
   нц пока j <= 10
     P:=P*A[i,j]
     j:=j+2
   кц
   i:=i+2
 кц

к алгоритмизации   алгоритмы, струкутуры данных и программирование   СУБД   ЯиМП   3GL   4GL   5GL   технологии прогр.

Знаете ли Вы, что примитивные конструкторы - это операции, которые создают объекты, соответствующего им типа, не используя никаких объектов в качестве аргументов. Примером такой операции является создание пустого списка.

Bourabai Research Institution home page

Bourabai Research - Технологии XXI века Bourabai Research Institution