Синтаксис языка 1С
Подходит начинающий програмист к хакеру и показывает программу на Бейсике.
- Подскажите, пожалуйста, в чем у меня ошибка?
- В ДНК, - вздыхает хакер.

 

 

Язык 1С очень похож на Бейсик. В 1С все ключевые слова можно писать по-русски.

Конструкция языка 1С

Примечание

Процедура РассчитатьНалог(Сотрудник, НекаяДата)

КонецПроцедуры

Простая процедура. После слова КонецПроцедуры точка с запятой не нужна, потому что это не оператор, а операторная скобка

Функция РассчитатьНалог(Сотрудник, НекаяДата)

Возврат Налог;

КонецФункции

Функция должна обязательно возвращать результат.

Если Оклад > 10000 Тогда
......Результат = "Нормально";
Иначе
......Результат = "Плохо";
КонецЕсли
;

Простое условие. После слова КонецЕсли должна быть точка с запятой, потому что так заканчивается оператор Если

Результат = ?(Оклад > 10000, "Нормально","Плохо"); Сокращенное Если.
Если Оклад > 10000 Тогда
......Результат = "Нормально";

ИначеЕсли Оклад > 5000 Тогда
......Результат = "Средне";

Иначе
......Результат = "Плохо";
КонецЕсли
;
Множественное условие. Если первое условие не выполняется, то проверяется второе. Если второе условие не выполняется, то третье. Если ни одно из условий не выполняется то выполняется блок Иначе.

Если (Оклад > 10000) И (КодКатегории = 2) Тогда

КонецЕсли;

В составном логическом выражении скобки обязательны!

Пока Номер <= 50 Цикл

КонецЦикла;

Простой цикл Пока (цикл с неизвестным числом повторений). После слова КонецЦикла должна быть точка с запятой, потому что так заканчивается оператор Пока
Для Номер = 1 По 50 Цикл

КонецЦикла;

Простой цикл Для (цикл с известным числом повторений).

Перейти ~метка;

<...>

~метка:

Так оформляются метки и оператор безусловного перехода (GOTO). Чем меньше в вашей программе будет меток, тем лучше.

Пока <условие> Цикл

Если <условие> Тогда
........Продолжить;
КонецЕсли;

КонецЦикла;

Оператор Продолжить передает управление в начало цикла.

Пока <условие> Цикл

Если <условие> Тогда
.........Прервать;
КонецЕсли;

КонецЦикла;

Оператор Прервать производит досрочный выход из цикла. Управление передается на операторы после цикла.
Перем Сотр; Явное объявление переменной.
Номер = 1; Переменные можно не объявлять явно. При первом присвоении значения создается новая переменная.
ФИО = Фамилия + " " + Имя + " " + Отчество; Сложение строк (конкатенация)
НекаяДата = '01.01.2002'; Переменная, которая хранит дату.
Перем глТекущийПользователь Экспорт; Объявление глобальной переменной в Глобальном модуле. Такие переменные доступны в любом месте конфигурации.

Попытка

а = 10 / 0;

Исключение

Предупреждение("Деление на ноль!");

КонецПопытки;

Обработка исключительных ситуаций.

Если во время выполнения операторов между словами Попытка и Исключение произошла ошибка, то управление передается на операторы между словами Исключение и КонецПопытки

Если ошибки не было, то управление передается на операторы после слова КонецПопытки.

//это комментарий Так оформляются комментарии.
СпрСотр.ВыбратьЭлементы(); Вызов метода объекта производится как обычно, через точку.

к оглавлению

Знаете ли Вы, низкочастотные электромагнитные волны частотой менее 100 КГц коренным образом отличаются от более высоких частот падением скорости электромагнитных волн пропорционально корню квадратному их частоты от 300 тыс. км/с при 100 кГц до примерно 7 тыс км/с при 50 Гц.

НОВОСТИ ФОРУМА

Форум Рыцари теории эфира


Рыцари теории эфира
 10.11.2021 - 12:37: ПЕРСОНАЛИИ - Personalias -> WHO IS WHO - КТО ЕСТЬ КТО - Карим_Хайдаров.
10.11.2021 - 12:36: СОВЕСТЬ - Conscience -> РАСЧЕЛОВЕЧИВАНИЕ ЧЕЛОВЕКА. КОМУ ЭТО НАДО? - Карим_Хайдаров.
10.11.2021 - 12:36: ВОСПИТАНИЕ, ПРОСВЕЩЕНИЕ, ОБРАЗОВАНИЕ - Upbringing, Inlightening, Education -> Просвещение от д.м.н. Александра Алексеевича Редько - Карим_Хайдаров.
10.11.2021 - 12:35: ЭКОЛОГИЯ - Ecology -> Биологическая безопасность населения - Карим_Хайдаров.
10.11.2021 - 12:34: ВОЙНА, ПОЛИТИКА И НАУКА - War, Politics and Science -> Проблема государственного терроризма - Карим_Хайдаров.
10.11.2021 - 12:34: ВОЙНА, ПОЛИТИКА И НАУКА - War, Politics and Science -> ПРАВОСУДИЯ.НЕТ - Карим_Хайдаров.
10.11.2021 - 12:34: ВОСПИТАНИЕ, ПРОСВЕЩЕНИЕ, ОБРАЗОВАНИЕ - Upbringing, Inlightening, Education -> Просвещение от Вадима Глогера, США - Карим_Хайдаров.
10.11.2021 - 09:18: НОВЫЕ ТЕХНОЛОГИИ - New Technologies -> Волновая генетика Петра Гаряева, 5G-контроль и управление - Карим_Хайдаров.
10.11.2021 - 09:18: ЭКОЛОГИЯ - Ecology -> ЭКОЛОГИЯ ДЛЯ ВСЕХ - Карим_Хайдаров.
10.11.2021 - 09:16: ЭКОЛОГИЯ - Ecology -> ПРОБЛЕМЫ МЕДИЦИНЫ - Карим_Хайдаров.
10.11.2021 - 09:15: ВОСПИТАНИЕ, ПРОСВЕЩЕНИЕ, ОБРАЗОВАНИЕ - Upbringing, Inlightening, Education -> Просвещение от Екатерины Коваленко - Карим_Хайдаров.
10.11.2021 - 09:13: ВОСПИТАНИЕ, ПРОСВЕЩЕНИЕ, ОБРАЗОВАНИЕ - Upbringing, Inlightening, Education -> Просвещение от Вильгельма Варкентина - Карим_Хайдаров.
Bourabai Research - Технологии XXI века Bourabai Research Institution